Ubislate 7Ci doesn't boot Ubislate 7Ci doesn't boot

Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 2 of 2

Thread: Ubislate 7Ci doesn't boot

  1. #1
    Right off the assembly line Reputation
    Join Date
    Dec 2012
    Post Thanks / Like

    General Ubislate 7Ci doesn't boot

    I have purchased Ubislate 7Ci tablet online.

    Currently after pressing power on button for few seconds may be 10-15 secs tablet switch on but it stuck on Android text logo on only and doesn't go any further, tried to boot several time still the same. I have charged tablet for several hours may be 4-5 hours still it stuck on text Android logo and then it goes off.

    Kindly guide me how to fix the issue.

  2. #2
    . Reputation Reputation Reputation Reputation thetechfreak's Avatar
    Join Date
    Nov 2008
    Post Thanks / Like

    General Re: Ubislate 7Ci doesn't boot

    Follow me on Twitter: https://twitter.com/wuodland

    Have a look at my Photography page: http://bit.ly/N2aMTi

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts